CVE-2024-5165

CVSS 3.1 Score 6.5 of 10 (medium)

Details

Published May 23, 2024
Updated: May 24, 2024
CWE ID 79

Summary

CVE-2024-5165 is a vulnerability that affects Eclipse Ditto versions 3.0.0 to 3.5.5. The user input for several input fields of the Eclipse Ditto Explorer User Interface was not properly neutralized, making it vulnerable to both Reflected and Stored Cross-Site Scripting (XSS). In some cases, the inputs were only stored in local browser storage, resulting in a Reflected XSS vulnerability. However, in other cases, the inputs were persisted at the backend, leading to a Stored XSS vulnerability. This means that authenticated and authorized users can inject scripts into the browser of other users who are authorized to view certain content in the Eclipse Ditto UI. The vulnerability has a risk score of 30, a base severity of MEDIUM, and an exploitability score of 2.8.

Leverage our Vulnerability Intelligence module to secure your systems now - get detailed insights on CVE-2024-37364. Book your demo today.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-5165 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options