CVE-2024-32019

CVSS 3.1 Score 8.8 of 10 (high)

Details

Published Apr 12, 2024
Updated: Apr 15, 2024
CWE ID 426

Summary

CVE-2024-32019 is a vulnerability affecting the Netdata observability tool. The vulnerability allows an attacker to execute arbitrary programs with root permissions through the 'ndsudo' tool, which is packaged as a root-owned executable with the SUID bit set. The 'ndsudo' tool has a restricted set of external commands, but an attacker can control its search paths through the PATH environment variable. This means that an attacker can manipulate where 'ndsudo' looks for commands, potentially leading to local privilege escalation. The vulnerability has been addressed in versions 1.45.3 and 1.45.2-169, and users are advised to upgrade to these versions as there are no known workarounds. The vulnerability has a base severity of HIGH and poses a risk to organizations due to its potential impact on confidentiality and integrity.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-32019 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options