CVE-2024-23820

CVSS 3.1 Score 5.3 of 10 (medium)

Details

Published Jan 26, 2024
Updated: Feb 1, 2024
CWE ID 770
CWE ID 401

Summary

CVE-2024-23820 is a vulnerability affecting OpenFGA, an authorization/permission engine, in versions prior to 1.4.3. This vulnerability allows for a denial of service attack, where a call to ListObjects may not release memory properly, leading to an out of memory error and server termination when a large number of those calls are executed. The issue has been patched in version 1.4.3. The vulnerability poses a medium risk with a base severity score of 5.3, exploitability score of 1.6, and potential high availability impact. It affects several products and can potentially be exploited over the network with low privileges required and no user interaction needed.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-23820 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options