CVSS 3.1 Score 9.8 of 10 (high)


Published Jan 28, 2024
Updated: Mar 21, 2024


CVE-2024-23738 is a critical vulnerability that affects Postman version 10.22 and earlier on macOS. It allows a remote attacker to execute arbitrary code by exploiting the RunAsNode and enableNodeClilnspectArguments settings. The vendor disputes the accuracy of the report, claiming that remote code execution is not enabled. However, if exploited, this vulnerability poses a high risk to organizations as it can lead to unauthorized code execution. To remediate the issue, users should update Postman to a version beyond 10.22 and ensure that the affected settings are properly configured to prevent potential attacks.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-23738 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options