CVE-2024-22203

CVSS 3.1 Score 9.1 of 10 (high)

Details

Published Jan 23, 2024
Updated: Jan 30, 2024
CWE ID 918

Summary

CVE-2024-22203 is a vulnerability that affects Whoogle Search, a self-hosted metasearch engine. In versions prior to 0.8.4, the element method in app/routes.py does not properly validate user-controlled variables, leading to a server-side request forgery. This vulnerability allows an attacker to craft GET requests to internal and external resources on behalf of the server, potentially accessing resources on the internal network that are not accessible on the internet. The issue has been fixed in version 0.8.4 of Whoogle Search. Organizations using affected versions should update to the latest version to remediate this vulnerability. The base severity of this vulnerability is rated as CRITICAL with a CVSS score of 9.1, indicating a high level of impact on confidentiality and integrity of data.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-22203 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options