CVE-2024-21506

CVSS 3.1 Score 5.2 of 10 (medium)

Details

Published Apr 6, 2024
CWE ID 125

Summary

CVE-2024-21506 is a vulnerability found in versions of the package pymongo before 4.6.3. It is categorized as an Out-of-bounds Read vulnerability and has a base severity rating of MEDIUM. The vulnerability allows an attacker to force the parser to deserialize unmanaged memory by using a crafted payload. The parser throws an exception with a string when it tries to interpret bytes next to the buffer and encounters non-printable UTF-8 characters. This vulnerability poses a potential danger to organizations using affected versions of pymongo, as it could be exploited by an attacker with local access and required user interaction, compromising confidentiality and integrity. It is recommended to update to version 4.6.3 or later to remediate this vulnerability.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-21506 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options