CVSS 3.1 Score 6.4 of 10 (medium)


Published Feb 29, 2024


CVE-2024-1054 is a vulnerability found in the Booster for WooCommerce plugin for WordPress. This vulnerability allows authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts into pages that will execute whenever a user accesses an injected page. The vulnerability exists in all versions of the plugin up to and including 7.1.6, due to insufficient input sanitization and output escaping on user supplied attributes like 'color'. The risk score for this vulnerability is 25, with a base severity of MEDIUM. It has a CVSS (Common Vulnerability Scoring System) vector string of CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N. Remediation for this vulnerability would involve updating the Booster for WooCommerce plugin to a version beyond 7.1.6, where this issue has been fixed.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-1054 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options