CVSS 3.1 Score 6.8 of 10 (medium)


Published Dec 22, 2023
Updated: Jan 8, 2024
CWE ID 287
CWE ID 918
CWE ID 347


CVE-2023-50714 is a vulnerability in the yii2-authclient extension, affecting versions prior to 2.2.15. This vulnerability is related to the Oauth2 PKCE implementation and has two main issues. First, the authCodeVerifier should be removed after usage. Second, there is a risk of a downgrade attack if PKCE is relied upon for CSRF protection. The vulnerability has a base severity of MEDIUM with a CVSS score of 6.8, indicating high impact on confidentiality and integrity. The affected products include various versions of yii2-authclient. To remediate this vulnerability, users should update to version 2.2.15 or higher as there are no known workarounds available. Organizations using yii2-authclient should be aware of the potential dangers this vulnerability poses, such as compromised data and unauthorized access to sensitive information.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-50714 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options