CVE-2023-49293

CVSS 3.1 Score 6.1 of 10 (medium)

Details

Published Dec 4, 2023
Updated: Dec 8, 2023
CWE ID 79

Summary

CVE-2023-49293 is a vulnerability affecting the Vite website frontend framework. It allows for arbitrary HTML injection into the transformed output when the HTML transformation is manually invoked and the request URL is passed unmodified. This vulnerability affects only apps using `appType: 'custom'` and the default Vite HTML middleware, with an inline script in the HTML entry. To remediate this vulnerability, it is recommended to update to [email protected], [email protected], or [email protected]. The potential danger of this vulnerability lies in the ability for an attacker to inject malicious code into the transformed output, potentially leading to cross-site scripting (XSS) attacks.

Leverage our Vulnerability Intelligence module to secure your systems now - get detailed insights on CVE-2024-37364. Book your demo today.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-49293 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options