CVE-2023-39422

CVSS 3.1 Score 6.5 of 10 (medium)

Details

Published Sep 7, 2023
Updated: Sep 12, 2023
CWE ID 798

Summary

CVE-2023-39422 is a cyber vulnerability that affects the /irmdata/api/ endpoints of the IRM Next Generation booking engine. This vulnerability occurs because the HMAC tokens used for authentication are exposed in a JavaScript file loaded on the client side, rendering this safety mechanism ineffective. It has a base severity of MEDIUM with a base score of 6.5 according to the CVSS:3.1 vector string. The vulnerability does not require any privileges or user interaction and can be exploited over the network. It has a low impact on integrity and confidentiality, with no availability impact. The danger it poses to an organization is that it allows unauthorized individuals to gain access to sensitive information or perform malicious actions within the affected system. To remediate this vulnerability, organizations should ensure that sensitive information such as tokens or credentials are not exposed to clientside JavaScript files and implement stronger authentication mechanisms.

Leverage our Vulnerability Intelligence module to secure your systems now - get detailed insights on CVE-2024-37364. Book your demo today.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-39422 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options