CVE-2023-37544

CVSS 3.1 Score 7.5 of 10 (high)

Details

Published Dec 20, 2023
Updated: Jan 4, 2024
CWE ID 287

Summary

CVE-2023-37544 is an improper authentication vulnerability in Apache Pulsar WebSocket Proxy. This vulnerability allows an attacker to connect to the /pingpong endpoint without authentication. The affected products are Apache Pulsar WebSocket Proxy versions 2.8.0 through 2.8.*, 2.9.0 through 2.9.*, 2.10.0 through 2.10.4, and 2.11.0 through 2.11.1, as well as version 3.0.0. The potential danger posed by this vulnerability includes a denial of service due to the WebSocket Proxy accepting any connections, and excessive data transfer due to misuse of the WebSocket ping/pong feature. To remediate this vulnerability, users of Pulsar WebSocket Proxy version 2.10 should upgrade to at least version 2.10.5, users of version 2.11 should upgrade to at least version 2.11.2, and users of version 3.0 should upgrade to at least version 3.0.1. It is important for users running the Pulsar WebSocket Proxy for versions 2.8, 2.,9 and earlier to upgrade to one of the above patched versions in order to mitigate the risk associated with this vulnerability. (Source: [email protected])

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-37544 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options