CVE-2023-37271

CVSS Score of 10 (low)

Details

Published Jul 11, 2023
Updated: Jul 19, 2023
CWE ID 913

Summary

CVE-2023-37271, also known as the RestrictedPython vulnerability, affects all deployments of RestrictedPython that allow untrusted users to write Python code. Versions prior to 6.1 and 5.3 are vulnerable. The vulnerability allows an attacker with access to a RestrictedPython environment to break out of the restricted sandbox and potentially execute arbitrary code in the Python interpreter. This poses a high risk to organizations using Zope and Plone if administrators allow untrusted users to create and/or edit objects of type 'Script (Python)'. To remediate the vulnerability, it is recommended to update RestrictedPython to version 6.1 or 5.3 or later.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-37271 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options