CVE-2023-35169

CVSS Score of 10 (low)

Details

Published Jun 23, 2023
Updated: Jul 6, 2023
CWE ID 22

Summary

CVE-2023-35169 is a vulnerability affecting PHP-IMAP prior to version 5.3.0. It allows an unauthenticated user to exploit a directory traversal vulnerability, leading to remote code execution. The vulnerability affects applications that store attachments using the `Attachment::save()` method without providing a filename or passing unsanitized user input. Attackers can send an email with a malicious attachment to the inbox, which is crawled by `webklex/php-imap` or `webklex/laravel-imap`. Remediation involves updating PHP-IMAP to version 5.3.0 or higher and ensuring proper sanitization of attachment filenames provided in the `Attachment::save()` method. This vulnerability poses a high risk to organizations as it can lead to unauthorized code execution and potential compromise of the affected system's confidentiality, integrity, and availability.

Leverage our Vulnerability Intelligence module to secure your systems now - get detailed insights on CVE-2024-37364. Book your demo today.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-35169 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options