CVE-2023-3342

CVSS 3.1 Score 9.9 of 10 (high)

Details

Published Jul 13, 2023
Updated: Nov 7, 2023
CWE ID 434

Summary

CVE-2023-3342 is a critical vulnerability affecting the User Registration plugin for WordPress versions up to and including 3.0.2. The vulnerability allows authenticated attackers with subscriber-level capabilities or higher to upload arbitrary files on the affected site's server, potentially leading to remote code execution. The issue arises from a hardcoded encryption key and missing file type validation in the 'ur_upload_profile_pic' function. The vulnerability was partially patched in version 3.0.2 and fully patched in version 3.0.2.1. Organizations using the affected versions of the User Registration plugin should update to the latest version immediately to mitigate this risk of unauthorized file uploads and potential remote code execution on their WordPress sites.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-3342 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options