CVSS Score of 10 (low)


Published Jul 22, 2023
Updated: Aug 1, 2023
CWE ID 252
CWE ID 330


CVE-2023-3247 is a vulnerability found in PHP versions 8.0.* before 8.0.29, 8.1.* before 8.1.20, and 8.2.* before 8.2.7 that affects products like mpPu4n, mpPu4m, and mpPu4l, among others. The vulnerability arises when using SOAP HTTP Digest Authentication, as the random value generator fails to check for failure and utilizes a narrower range of values than intended. This can lead to the disclosure of uninitialized memory from the client to the server, potentially compromising sensitive information. Remediation involves updating PHP to versions 8.0.29, 8.1.20, or 8.2.7 to address the issue and mitigate potential risks to organizations utilizing these affected versions of PHP.

Leverage our Vulnerability Intelligence module to secure your systems now - get detailed insights on CVE-2024-37364. Book your demo today.


Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-3247 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options