CVE-2024-6507

CVSS 3.1 Score 8.1 of 10 (high)

Details

Published Jul 4, 2024
Updated: Jul 8, 2024
CWE ID 94

Summary

CVE-2024-6507 is a high-severity vulnerability categorized as CWE-94 (Improper Control of Generation of Code) that affects multiple products including w0LXQh, w0NV95, w0LXQg, w0NV94, w0LXQi, w0NV96, w0NEoe, w0NEof, w0NEog, w0NV93, and w0NV92. The vulnerability allows for command injection when ingesting a remote Kaggle dataset due to a lack of input sanitization in the ingest_kaggle() API. It has a base score of 8.1 and impacts confidentiality and integrity. The exploitability score is 2.2 and the attack vector is network-based with no privileges required. Remediation steps are not provided in the available information.

Prevent cyber attacks with Recorded Future by prioritizing and patching critical vulnerabilities being exploited by threat actors targeting your industry. Book your demo to learn more.

Share

Prioritize, Pinpoint, and Act to Prevent Vulnerability Exploits with Recorded Future

Note: This is just a basic overview providing quick insights into CVE-2024-6507 information. Gain full access to comprehensive CVE data, third party vulnerabilities, compromised credentials and more with Recorded Future
  • Gain complete coverage of your cyber, third party, and physical attack surface
  • Proactively mitigate threats before they turn into costly attacks
  • Make fast, effective, data-driven decisions