CVE-2024-6376

CVSS 3.1 Score 7.0 of 10 (high)

Details

Published Jul 1, 2024
Updated: Jul 3, 2024
CWE ID 94
CWE ID 20

Summary

CVE-2024-6376 is a code injection vulnerability that affects MongoDB Compass versions prior to 1.42.2. This vulnerability is caused by insufficient sandbox protection settings in the ejson shell parser used in Compass' connection handling. The vulnerability has a base severity rating of HIGH with a CVSS score of 7.0, indicating a significant potential danger to organizations. The exploitability score is 1.0, meaning it is easily exploitable without requiring any special privileges. The attack vector is local, and the impact includes high integrity and confidentiality impacts as well as high availability impact. To remediate this vulnerability, organizations should update MongoDB Compass to version 1.42.2 or newer.

Prevent cyber attacks with Recorded Future by prioritizing and patching critical vulnerabilities being exploited by threat actors targeting your industry. Book your demo to learn more.

Share

Prioritize, Pinpoint, and Act to Prevent Vulnerability Exploits with Recorded Future

Note: This is just a basic overview providing quick insights into CVE-2024-6376 information. Gain full access to comprehensive CVE data, third party vulnerabilities, compromised credentials and more with Recorded Future
  • Gain complete coverage of your cyber, third party, and physical attack surface
  • Proactively mitigate threats before they turn into costly attacks
  • Make fast, effective, data-driven decisions