CVE-2024-6323

CVSS 3.1 Score 7.5 of 10 (high)

Details

Published Jun 27, 2024
Updated: Jun 28, 2024
CWE ID 653
CWE ID 863

Summary

CVE-2024-6323 is a vulnerability in GitLab EE that affects all versions from 16.11 prior to 16.11.5 and 17.0 prior to 17.0.3 and 17.1 prior to 17.1.1. This vulnerability allows an attacker to leak content of a private repository in a public project due to improper authorization in the global search feature. The vulnerability has a high severity rating and a base score of 7.5 according to the NVD database, indicating its potential danger to an organization's confidentiality. The exploitability score is 3.9, suggesting that it is relatively easy for attackers to exploit this vulnerability over the network without requiring any privileges or user interaction. The vulnerability does not impact integrity or availability and has been categorized as CWE-863 (Incorrect Authorization). It is recommended that affected organizations update their GitLab EE installations to versions 16.11.5, 17.0.3, or 17.1.1 in order to remediate this vulnerability and prevent potential data leaks from private repositories.

Prevent cyber attacks with Recorded Future by prioritizing and patching critical vulnerabilities being exploited by threat actors targeting your industry. Book your demo to learn more.

Share

Prioritize, Pinpoint, and Act to Prevent Vulnerability Exploits with Recorded Future

Note: This is just a basic overview providing quick insights into CVE-2024-6323 information. Gain full access to comprehensive CVE data, third party vulnerabilities, compromised credentials and more with Recorded Future
  • Gain complete coverage of your cyber, third party, and physical attack surface
  • Proactively mitigate threats before they turn into costly attacks
  • Make fast, effective, data-driven decisions