CVSS 3.1 Score 6.4 of 10 (medium)


Published Jun 14, 2024
Updated: Jun 17, 2024


CVE-2024-5994 is a vulnerability found in the WP Go Maps plugin for WordPress, affecting versions up to 9.0.38. It allows authenticated attackers with contributor-level permissions or above to inject arbitrary web scripts through the Custom JS option, resulting in stored cross-site scripting (XSS) attacks. The injected scripts can execute whenever a user accesses the affected pages. However, version 9.0.39 has been released to address this issue and adds a warning for administrators regarding the potential abuse of lower-level user permissions. The vulnerability has a risk score of 25 and is rated as medium severity, with low privileges required and no user interaction needed for exploitation. The impact on integrity and confidentiality is considered low, and the attack vector is through the network.

Prevent cyber attacks with Recorded Future by prioritizing and patching critical vulnerabilities being exploited by threat actors targeting your industry. Book your demo to learn more.


Prioritize, Pinpoint, and Act to Prevent Vulnerability Exploits with Recorded Future

Note: This is just a basic overview providing quick insights into CVE-2024-5994 information. Gain full access to comprehensive CVE data, third party vulnerabilities, compromised credentials and more with Recorded Future
  • Gain complete coverage of your cyber, third party, and physical attack surface
  • Proactively mitigate threats before they turn into costly attacks
  • Make fast, effective, data-driven decisions