CVE-2024-5871

CVSS 3.1 Score 9.8 of 10 (high)

Details

Published Jun 15, 2024
Updated: Jun 17, 2024

Summary

CVE-2024-5871 is a vulnerability found in the WooCommerce - Social Login plugin for WordPress, affecting all versions up to and including 2.6.2. The vulnerability allows for PHP Object Injection through deserialization of untrusted input from the 'woo_slg_verify' parameter. This could be exploited by unauthenticated attackers to inject a PHP object, potentially leading to the deletion of arbitrary files, retrieval of sensitive data, or code execution. No known POP chain is present in the vulnerable software, but if a POP chain exists through an additional plugin or theme installed on the target system, the impact could be more severe.

Prevent cyber attacks with Recorded Future by prioritizing and patching critical vulnerabilities being exploited by threat actors targeting your industry. Book your demo to learn more.

Share

Prioritize, Pinpoint, and Act to Prevent Vulnerability Exploits with Recorded Future

Note: This is just a basic overview providing quick insights into CVE-2024-5871 information. Gain full access to comprehensive CVE data, third party vulnerabilities, compromised credentials and more with Recorded Future
  • Gain complete coverage of your cyber, third party, and physical attack surface
  • Proactively mitigate threats before they turn into costly attacks
  • Make fast, effective, data-driven decisions