CVE-2024-5798

CVSS 3.1 Score 2.6 of 10 (low)

Details

Published Jun 12, 2024
Updated: Jun 13, 2024
CWE ID 285

Summary

The vulnerability with the CVE ID CVE-2024-5798 affects Vault and Vault Enterprise versions prior to 1.17.0, 1.16.3, and 1.15.9. It is related to the improper validation of the JSON Web Token (JWT) role-bound audience claim when using the Vault JWT auth method. This vulnerability could allow an invalid login to succeed when it should have been rejected, due to a mismatch between the audience and role-bound claims in the JWT. The base severity of this vulnerability is rated as LOW, with a base score of 2.6 according to CVSS version 3.1. The remediation for this vulnerability is to update Vault and Vault Enterprise to the fixed versions mentioned above to mitigate the risk of unauthorized access or exploitation of sensitive data stored within these systems.

Prevent cyber attacks with Recorded Future by prioritizing and patching critical vulnerabilities being exploited by threat actors targeting your industry. Book your demo to learn more.

Share

Prioritize, Pinpoint, and Act to Prevent Vulnerability Exploits with Recorded Future

Note: This is just a basic overview providing quick insights into CVE-2024-5798 information. Gain full access to comprehensive CVE data, third party vulnerabilities, compromised credentials and more with Recorded Future
  • Gain complete coverage of your cyber, third party, and physical attack surface
  • Proactively mitigate threats before they turn into costly attacks
  • Make fast, effective, data-driven decisions