CVE-2024-5674

CVSS 3.1 Score 6.5 of 10 (medium)

Details

Published Jun 12, 2024

Summary

CVE-2024-5674 is a vulnerability in the Newsletter - API v1 and v2 addon plugin for WordPress. The vulnerability exists in all versions up to and including 2.4.5, and it is caused by a PHP type juggling issue in the check_api_key function. Attackers who are not authenticated can exploit this vulnerability to manage newsletter subscribers, including listing, creating, or deleting them. However, this vulnerability only affects websites running PHP versions below 8.0. The risk score is rated at 25, with a base severity of MEDIUM and a base score of 6.5 according to [email protected]. The impact on integrity and confidentiality is rated as LOW, with no impact on availability.

Prevent cyber attacks with Recorded Future by prioritizing and patching critical vulnerabilities being exploited by threat actors targeting your industry. Book your demo to learn more.

Share

Prioritize, Pinpoint, and Act to Prevent Vulnerability Exploits with Recorded Future

Note: This is just a basic overview providing quick insights into CVE-2024-5674 information. Gain full access to comprehensive CVE data, third party vulnerabilities, compromised credentials and more with Recorded Future
  • Gain complete coverage of your cyber, third party, and physical attack surface
  • Proactively mitigate threats before they turn into costly attacks
  • Make fast, effective, data-driven decisions