CVE-2024-5654

CVSS 3.1 Score 6.5 of 10 (medium)

Details

Published Jun 8, 2024
Updated: Jun 10, 2024

Summary

CVE-2024-5654 is a vulnerability found in the CF7 Google Sheets Connector plugin for WordPress. All versions up to and including 5.0.9 are affected by this vulnerability, which allows unauthenticated attackers to modify data without authorization. Specifically, the 'execute_post_data_cg7_free' function lacks a capability check, enabling attackers to manipulate site configuration settings such as WP_DEBUG, WP_DEBUG_LOG, SCRIPT_DEBUG, and SAVEQUERIES. This vulnerability poses a medium risk with a base severity score of 6.5 out of 10 according to analysis by [email protected]. The exploitability score is 3.9 out of 10, and the impact score is 2.5 out of 10. It is important for organizations using this plugin to upgrade to a version that addresses this vulnerability promptly in order to mitigate potential unauthorized data modifications and maintain the integrity and confidentiality of their WordPress websites.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-5654 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options