CVE-2024-5031

CVSS 3.1 Score 8.5 of 10 (high)

Details

Published May 22, 2024

Summary

CVE-2024-5031 is a vulnerability affecting the Memberpress plugin for WordPress in all versions up to and including 1.11.29. This vulnerability allows authenticated attackers with Contributor-level access or higher to make web requests to arbitrary locations from the web application, resulting in Blind Server-Side Request Forgery. The vulnerability can be exploited through the 'mepr-user-file' shortcode, enabling attackers to query and modify internal services. The risk score for this vulnerability is 65 out of 100, indicating a high level of danger. To remediate the issue, it is recommended to update the affected Memberpress plugin to a version beyond 1.11.29 or apply any available patches or fixes provided by the plugin developer.

Leverage our Vulnerability Intelligence module to secure your systems now - get detailed insights on CVE-2024-37364. Book your demo today.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-5031 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options