CVSS 3.1 Score 5.4 of 10 (medium)


Published May 14, 2024


CVE-2024-4860 is a Cross-Site Scripting (XSS) vulnerability affecting the 'WordPress RSS Aggregator' WordPress Plugin versions < 4.23.9. The vulnerability arises due to the lack of sanitization of the 'notice_id' GET parameter. It has a base severity rating of MEDIUM with a base score of 5.4 according to CVSS version 3.1. The exploitability score is 2.8, and it requires user interaction over a network with no privileges required. The impact on confidentiality and integrity is low, while the attack complexity is low as well. This vulnerability poses a potential danger to organizations that use affected versions of the plugin as it allows for the execution of arbitrary script code on targeted websites, potentially leading to unauthorized access or data theft. To remediate this vulnerability, users should update their WordPress RSS Aggregator plugin to version 4.23.9 or newer, which addresses this issue and ensures the proper sanitization of input during web page generation, mitigating the risk of XSS attacks.


Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-4860 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options