CVE-2024-4035

CVSS 3.1 Score 6.4 of 10 (medium)

Details

Published Apr 25, 2024

Summary

CVE-2024-4035 is a vulnerability affecting the Photo Gallery – GT3 Image Gallery & Gutenberg Block Gallery plugin for WordPress versions up to and including 2.7.7.21. The vulnerability allows authenticated attackers with author-level access or higher to inject arbitrary web scripts via image alt text, leading to stored cross-site scripting (XSS) attacks. This can potentially compromise the security of the website and execute malicious scripts whenever a user visits an injected page. The risk score assigned to this vulnerability is 25, with a medium base severity score of 6.4. Remediation for this vulnerability would require updating the plugin to a version that includes input sanitization and output escaping improvements to mitigate the XSS attack vector.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-4035 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options