CVE-2024-4014

CVSS 3.1 Score 6.4 of 10 (medium)

Details

Published Apr 20, 2024
Updated: Apr 22, 2024

Summary

The hCaptcha for WordPress plugin for WordPress, up to version 4.0.0, is vulnerable to Stored Cross-Site Scripting (XSS) due to insufficient input sanitization and output escaping on user supplied attributes within the plugin's cf7-hcaptcha shortcode. This flaw allows authenticated attackers with contributor-level access or higher to inject arbitrary web scripts into pages, which will execute whenever a user accesses the affected page. The vulnerability has a CVE ID of CVE-2024-4014 and has a base severity rating of MEDIUM with a base score of 6.4 according to the CVSS:3.1 scoring system. The exploitability score is 3.1, indicating that it is moderately easy to exploit. The risk score associated with this vulnerability is 30 out of 100. Remediation measures should be taken promptly to mitigate the potential danger posed by this vulnerability in organizations using the hCaptcha for WordPress plugin for WordPress versions up to and including 4.0.0.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-4014 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options