CVSS 3.1 Score 5.4 of 10 (medium)


Published Apr 25, 2024


CVE-2024-3994 is a vulnerability affecting the Tutor LMS plugin for WordPress. The vulnerability allows for Stored Cross-Site Scripting through the plugin's 'tutor_instructor_list' shortcode, due to insufficient input sanitization and output escaping. This means that authenticated attackers with contributor-level access or higher can inject malicious web scripts into pages, which will be executed when accessed by users. The risk score for this vulnerability is 25, with a base severity of MEDIUM. The exploitability score is 2.8, indicating a relatively low level of difficulty in exploiting the vulnerability. It has a low impact on integrity and confidentiality but does not affect availability. To remediate this vulnerability, users should update to version 2.6.3 or newer of the Tutor LMS plugin.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-3994 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options