CVE-2024-37150

CVSS 3.1 Score 7.6 of 10 (high)

Details

Published Jun 6, 2024
Updated: Jun 7, 2024
CWE ID 200

Summary

CVE-2024-37150 is a vulnerability that affects Deno 1.44.0 and potentially impacts all users relying on .npmrc. The vulnerability occurs when Deno sends .npmrc credentials for the scope to the tarball URL, if the registry provided URLs for a tarball on a different domain. This vulnerability can be exploited by attackers who have access to the tarball URL of a private registry at a different domain. To remediate this vulnerability, it is recommended to upgrade to Deno 1.44.1 and rotate registry credentials if the private registry serves tarballs at a different domain. The potential danger of this vulnerability lies in the exposure of sensitive credentials, which could lead to unauthorized access or information disclosure in an organization using Deno with .npmrc.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-37150 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options