CVE-2024-3514

CVSS 3.1 Score 6.4 of 10 (medium)

Details

Published Apr 9, 2024
Updated: Apr 10, 2024

Summary

CVE-2024-3514 is a vulnerability found in the Responsive Tabs plugin for WordPress. This vulnerability affects all versions up to and including 4.0.6. It allows authenticated attackers with contributor-level access or higher to inject arbitrary web scripts into pages, leading to stored cross-site scripting (XSS). The vulnerability is caused by insufficient input sanitization and output escaping on user supplied attributes, specifically the tabs_color value. The potential danger of this vulnerability is that whenever a user accesses an injected page, the injected web scripts will execute. To remediate this vulnerability, users should update to the latest version of the plugin that includes proper input sanitization and output escaping measures.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-3514 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options