CVE-2024-34347

CVSS 3.1 Score 8.3 of 10 (high)

Details

Published May 8, 2024
CWE ID 77

Summary

CVE-2024-34347 is a vulnerability that affects the @hoppscotch/cli CLI tool, specifically versions prior to 0.8.0. The vulnerability is related to the @hoppscotch/js-sandbox package, which utilizes the Node.js vm module for sandboxing untrusted JavaScript code. However, the vm module is not secure for this purpose as code inside the vm context can break out if it obtains a reference to an object created outside of the vm. This allows the pre-request script to escape the sandbox and potentially pose a high risk to organizations using this tool. The vulnerability has been addressed and fixed in version 0.8.0 of @hoppscotch/cli.

Leverage our Vulnerability Intelligence module to secure your systems now - get detailed insights on CVE-2024-37364. Book your demo today.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-34347 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options