CVE-2024-32644

CVSS 3.1 Score 9.1 of 10 (high)

Details

Published Apr 19, 2024
CWE ID 662

Summary

CVE-2024-32644 is a critical vulnerability affecting Evmos, a Proof-of-Stake EVM blockchain that is compatible with Ethereum. The vulnerability exists in versions prior to 17.0.0 and allows for the arbitrary minting of tokens due to a discrepancy between the Cosmos SDK state and the EVM state during transaction execution. Exploiting this vulnerability could lead to the drain of funds through interactions with smart contracts. The issue has been patched, but organizations using affected versions should update to the latest version to remediate this vulnerability.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-32644 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options