CVE-2024-3107

CVSS 3.1 Score 4.3 of 10 (medium)

Details

Published May 2, 2024

Summary

CVE-2024-3107 is a vulnerability found in the Spectra – WordPress Gutenberg Blocks plugin for WordPress, specifically in versions up to and including 2.12.6. The vulnerability allows authenticated attackers with contributor-level permissions and above to perform Path Traversal attacks through the get_block_default_attributes function. This can enable them to read the contents of any files named attributes.php on the server, potentially exposing sensitive information. The risk score for this vulnerability is 5, with a base severity of medium. The exploitability score is 2.8, and the potential impact includes low confidentiality impact and no integrity or availability impact. Remediation measures should be implemented promptly to mitigate the risk posed by this vulnerability.

Source: Security@wordfence.com

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-3107 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options