CVE-2024-29904

CVSS 3.1 Score 7.5 of 10 (high)

Details

Published Mar 29, 2024
Updated: Apr 1, 2024
CWE ID 835

Summary

CVE-2024-29904 is a vulnerability in the Language class of the CodeIgniter PHP full-stack web framework. This vulnerability allows for denial-of-service (DoS) attacks by exploiting the vulnerability to consume excessive server memory. To remediate this issue, it is recommended to upgrade to version 4.4.7 or later. The potential danger posed by this vulnerability is high, as it can disrupt the availability of the affected server and impact the overall functionality of an organization's web applications.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-29904 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options