CVE-2024-29894

CVSS 3.1 Score 5.4 of 10 (medium)

Details

Published May 14, 2024
CWE ID 116
CWE ID 79

Summary

CVE-2024-29894 is a residual cross-site scripting vulnerability found in versions of Cacti prior to 1.2.27. The vulnerability is caused by an incomplete fix for CVE-2023-50250. The vulnerability exists in the `raise_message_javascript` function in `lib/functions.php`, where unescaped PHP variables `$title` and `$header` can be used to inject JavaScript code if they contain single quotes. Exploiting this vulnerability could allow an attacker to execute actions on behalf of other users, potentially leading to unauthorized changes to settings. To remediate this issue, organizations should upgrade to Cacti version 1.2.27, which fixes the vulnerability. The severity of this vulnerability is rated as MEDIUM with a base score of 5.4 according to CVSS version 3.1, and it requires user interaction over a network with low attack complexity and low impact on confidentiality and availability.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-29894 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options