CVE-2024-29882

CVSS 3.1 Score 7.2 of 10 (high)

Details

Published Mar 28, 2024
CWE ID 79

Summary

CVE-2024-29882 is a vulnerability that affects SRS, a real-time video server. The vulnerability exists in the /api/v1/vhosts/vid-<id>?callback=<payload> endpoint, where the callback function name was not properly filtered, allowing for the injection of malicious JavaScript payloads and enabling Cross-Site Scripting (XSS) attacks. The vulnerability has been addressed in versions 5.0.210 and 6.0.121 of SRS. This vulnerability poses a high risk to organizations as it allows attackers to execute arbitrary code on the affected server, potentially leading to unauthorized access or data manipulation. Organizations should update their SRS installations to the fixed versions to mitigate this vulnerability and ensure the security of their systems.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-29882 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options