CVE-2024-29034

CVSS 3.1 Score 6.8 of 10 (medium)

Details

Published Mar 24, 2024
Updated: Mar 25, 2024
CWE ID 436
CWE ID 79

Summary

CVE-2024-29034 is a vulnerability in CarrierWave, a file upload solution for Ruby web frameworks. The vulnerability arises from the incomplete resolution of CVE-2023-49090. It allows an attacker to bypass the content type restrictions and inject malicious code, potentially leading to cross-site scripting (XSS) attacks. To remediate this vulnerability, users are advised to upgrade to version 3.0.7 or 2.2.6 of CarrierWave. This vulnerability poses a medium risk to organizations, with low privileges required for exploitation and user interaction being necessary. The impact includes high confidentiality risks but no integrity or availability impact.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-29034 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options