CVE-2024-29033

CVSS 3.1 Score 7.5 of 10 (high)

Details

Published Mar 20, 2024
Updated: Mar 21, 2024
CWE ID 285

Summary

CVE-2024-29033 is an improper authorization vulnerability found in OAuthenticator, a plugin used by JupyterHub for authentication with OAuth providers. Prior to version 16.3.0, the restriction for Google accounts was based on email domains, allowing unauthorized accounts with emails ending with the domain to gain access. This issue was patched in version 16.3.0. To mitigate the vulnerability, organizations can restrict login access through other means such as specifying allowed users or Google groups. The vulnerability has a base severity rating of HIGH and a base score of 7.5 according to the Common Vulnerability Scoring System (CVSS). It poses a potential risk to organizations as it could allow unauthorized access to JupyterHub instances and potentially compromise sensitive information.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-29033 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options