CVE-2024-29025

CVSS 3.1 Score 5.3 of 10 (medium)

Details

Published Mar 25, 2024
Updated: Mar 26, 2024
CWE ID 770

Summary

CVE-2024-29025 is a vulnerability in the Netty framework, affecting version 4.1.108.Final and below. The vulnerability lies in the HttpPostRequestDecoder component, which can be manipulated to accumulate data without limits. An attacker could exploit this by sending a chunked post with many small fields that will accumulate in the system's memory. This vulnerability poses a medium risk to organizations as it could potentially lead to denial-of-service attacks or memory exhaustion. The issue has been fixed in version 4.1.108.Final, and organizations are advised to update their Netty installations to mitigate the risk.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-29025 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options