CVE-2024-2831

CVSS 3.1 Score 8.8 of 10 (high)

Details

Published May 2, 2024

Summary

CVE-2024-2831 is a vulnerability affecting the Calendar plugin for WordPress versions up to and including 1.3.14. It is classified as a SQL Injection vulnerability due to insufficient escaping on user-supplied parameters and lack of preparation on existing SQL queries. Authenticated attackers with contributor access or higher can exploit this vulnerability to append additional SQL queries and potentially extract sensitive information from the database. The risk score for this vulnerability is 66, indicating a high severity level. The exploitability score is 2.8, privileges required are low, and user interaction is not necessary. The attack vector is through the network, with high impact on integrity and confidentiality, as well as availability.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-2831 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options