CVE-2024-28198

CVSS 3.1 Score 4.6 of 10 (medium)

Details

Published Mar 11, 2024
Updated: Mar 12, 2024
CWE ID 611

Summary

CVE-2024-28198 is a vulnerability that affects OpenOlat, an open-source e-learning platform. This vulnerability allows an attacker to read arbitrary files and perform server-side request forgery (SSRF) by manipulating HTTP requests when using the draw.io integration. The issue has been fixed in versions 18.1.6 and 18.2.2 of OpenOlat, and it is recommended to upgrade to the latest version of 18.1.x or 18.2.x. Alternatively, users can mitigate this issue by disabling the Draw.io module or the entire REST API to secure the system. The vulnerability has a CVSS score of 4.6, indicating a medium severity level, with low privileges required and user interaction required for exploitation. The impact on confidentiality and integrity is low, and the exploitability score is 1.2 out of 10, suggesting a relatively low likelihood of successful exploitation.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-28198 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options