CVE-2024-28120

CVSS 3.1 Score 6.5 of 10 (medium)

Details

Published Mar 11, 2024
Updated: Mar 12, 2024
CWE ID 284
CWE ID 200

Summary

CVE-2024-28120 is a vulnerability affecting codeium-chrome, an open-source code completion plugin for the Chrome web browser. The issue lies in the service worker of the extension, which fails to verify the sender when receiving an external message. This allows an attacker to create a malicious website that can steal the user's Codeium API key, enabling them to impersonate the user on the backend autocomplete server. As of now, there is no fix or patch available for this vulnerability. Users are advised to closely monitor their API key usage to mitigate potential risks and unauthorized access to their accounts. The severity of this vulnerability is rated as medium, with a base score of 6.5 out of 10.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-28120 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options