CVE-2024-28108

CVSS 3.1 Score 4.7 of 10 (medium)

Details

Published Mar 25, 2024
Updated: Mar 26, 2024
CWE ID 79
CWE ID 80

Summary

CVE-2024-28108 is a vulnerability in the phpMyFAQ open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL, and other databases. The vulnerability arises due to insufficient validation on the "contentLink" parameter, allowing unauthenticated users to inject HTML code onto the page, potentially affecting other users. To remediate this vulnerability, it is recommended to update to version 3.2.6 of phpMyFAQ. This vulnerability poses a medium-level danger as it requires certain conditions to be met, such as allowing guests to add new FAQs and the admin not checking the content of newly added FAQs.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-28108 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options