CVSS 3.1 Score 4.3 of 10 (medium)


Published Mar 25, 2024
Updated: Mar 26, 2024


CVE-2024-28106 is a vulnerability that affects phpMyFAQ, an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL, and other databases. By manipulating the news parameter in a POST request, an attacker can inject malicious JavaScript code. When the compromised news page is accessed, the XSS payload will be triggered. This vulnerability has been fixed in version 3.2.6 of phpMyFAQ. The exploitability score is 0.9, indicating a medium base severity and base score of 4.3. It requires high privileges and user interaction on a network attack vector, with low impact on integrity and confidentiality. The CWE category for this vulnerability is CWE-79, which refers to improper neutralization of input during web page generation (cross-site scripting).

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-28106 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options