CVE-2024-27936

CVSS 3.1 Score 8.8 of 10 (high)

Details

Published Mar 21, 2024
CWE ID 150

Summary

CVE-2024-27936 is a vulnerability affecting the deno_runtime library versions prior to 1.41. A maliciously crafted permission request can display a spoofed permission prompt by inserting a broken ANSI escape sequence into the request contents. While Deno strips ANSI escape sequences from the prompt, the permissions granted to the program are based on the contents that contain these sequences. This allows a malicious Deno program to deceive users by displaying incorrect file paths or program names. To remediate this issue, organizations should update to version 1.41 of the deno_runtime library, which includes a patch. The vulnerability has a high severity level with potential impacts on integrity and confidentiality, and it requires user interaction and network access for exploitation. The CVSS vector string for this vulnerability is CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-27936 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options