CVE-2024-27894

CVSS 3.1 Score 8.5 of 10 (high)

Details

Published Mar 12, 2024
Updated: Mar 13, 2024
CWE ID 552
CWE ID 20

Summary

CVE-2024-27894 is a cyber vulnerability that affects the Pulsar Functions Worker and Pulsar Broker when configured with "functionsWorkerEnabled". This vulnerability allows authenticated users to create functions with implementation referenced by a URL, which can be exploited by an attacker to gain unauthorized access to files and sensitive information that the Pulsar Functions Worker process has permissions to read. The attacker can also use the worker as a proxy to access remote HTTP and HTTPS endpoint URLs, potentially carrying out denial of service attacks. The risk score for this vulnerability is 65, with a base severity of HIGH and base score of 8.5 according to CVSS:3.1. Remediation measures should be taken to address this vulnerability and prevent potential security breaches.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-27894 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options