CVSS 3.1 Score 4.3 of 10 (medium)


Published Feb 28, 2024
CWE ID 200


CVE-2024-27315 is a vulnerability that affects Apache Superset versions before 3.0.4 and from 3.1.0 before 3.1.1. It allows an authenticated user with privileges to create Alerts on Alerts & Reports to generate a specially crafted SQL statement that triggers an error on the database, which could potentially expose sensitive data in the error log of the Alert. The risk score is rated as 5, indicating a medium severity level. To remediate this vulnerability, users are advised to upgrade to either version 3.1.1 or 3.0.4, as these versions include the necessary fixes to address the issue.

Prevent cyber attacks with Recorded Future by prioritizing and patching critical vulnerabilities being exploited by threat actors targeting your industry. Book your demo to learn more.


Prioritize, Pinpoint, and Act to Prevent Vulnerability Exploits with Recorded Future

Note: This is just a basic overview providing quick insights into CVE-2024-27315 information. Gain full access to comprehensive CVE data, third party vulnerabilities, compromised credentials and more with Recorded Future
  • Gain complete coverage of your cyber, third party, and physical attack surface
  • Proactively mitigate threats before they turn into costly attacks
  • Make fast, effective, data-driven decisions