CVE-2024-27307

CVSS 3.1 Score 9.8 of 10 (high)

Details

Published Mar 6, 2024
CWE ID 1321

Summary

CVE-2024-27307 is a cyber vulnerability that affects JSONata versions 1.4.0 and prior to 1.8.7 and 2.0.4, a JSON query and transformation language. It allows a malicious expression to override properties on the Object constructor and prototype, potentially leading to denial of service, remote code execution, or other unexpected behavior in applications that evaluate user-provided JSONata expressions. The issue has been fixed in versions 1.8.7 and 2.0.4, so it is recommended for applications that evaluate user-provided expressions to update as soon as possible to prevent exploitation. As a temporary workaround, the patch can be applied manually.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-27307 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options