CVE-2024-27101

CVSS 3.1 Score 7.3 of 10 (high)

Details

Published Mar 1, 2024
CWE ID 190

Summary

CVE-2024-27101 is a vulnerability in SpiceDB, an open-source database for managing security-critical application permissions. The vulnerability is caused by an integer overflow in the chunking helper, resulting in the dispatching process missing elements or causing a panic. Any SpiceDB cluster with a schema containing a resource that has more than 65535 relationships for the same resource and subject type is affected. The CheckPermission, BulkCheckPermission, and LookupSubjects API methods are all impacted. This vulnerability has been addressed in version 1.29.2 of SpiceDB. The vulnerability is rated as high severity with a CVSS score of 7.3, requiring high privileges and user interaction over a network to exploit. It has a high impact on integrity and availability but does not affect confidentiality.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-27101 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options