CVE-2024-26266

CVSS 3.1 Score 9.0 of 10 (high)

Details

Published Feb 21, 2024
Updated: Feb 22, 2024
CWE ID 79

Summary

CVE-2024-26266 is a critical vulnerability categorized as CWE-79 (Improper Neutralization of Input During Web Page Generation) affecting Liferay Portal versions 7.2.0 through 7.4.3.13, older unsupported versions, and Liferay DXP versions 7.4 before update 10, 7.3 before update 4, and 7.2 before fix pack 17, as well as older unsupported versions. This vulnerability allows remote authenticated users to inject arbitrary web script or HTML through a crafted payload in the first/middle/last name text field of the user creating an entry in either the Announcement widget or Alerts widget. The vulnerability enables stored cross-site scripting (XSS) attacks, posing a high risk to organizations by potentially compromising the confidentiality and integrity of user data. To remediate this vulnerability, affected organizations should update their Liferay Portal and Liferay DXP installations to the latest supported versions available.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-26266 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options